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ABOUT THE COURSE 
 

This comprehensive course is designed to 

empower you with the essential skills and tools to 

launch your very own WordPress website. SN 

TECH PROS created this course to break down 

tech education barriers, offering high-quality 

learning at a low cost or free. It empowers anyone 

to master WordPress web design and unlock new 

opportunities. 

Target audience  

The course targets beginners with no prior web 

design or WordPress experience.  

Course Goal  

Enable learners to confidently build, launch and 

manage a WordPress website. 

Course Delivery  

 Video tutorials with screen recordings. 

 Step-by-step written guides. 

 Downloadable resources (checklists, 

templates). 

 Q&A forums for student support. 

 Optional: Live Q&A sessions. 

 Project based learning, where each learner 

builds their own website. 

 

 

 

Hands On Project  
You will have the opportunity to 
build a hands-on WordPress Website 
called Awesome Bakery Project. his 
project guides you through creating a 
fully functional WordPress website 
for a fictional bakery called 
"Awesome Bakery." You’ll apply the 
skills from each module to plan, 
build, customize, enhance, and 
launch the site. Each module 
includes specific tasks to complete, 
culminating in a live website by 
Module 5. Follow the step-by-step 
instructions to create a professional, 
responsive site showcasing the 
bakery’s products, story, and contact 
details. 
Project Overview 

• Website Purpose: Promote 
Awesome Bakery, display its 
menu, share its story, and 
allow customers to contact 
the business. 

• Target Audience: Local 
customers looking for baked 
goods, including cakes, 
pastries, and bread. 

• Key Features: 
o Homepage with a 

welcoming banner 
and featured 
products. 

o About Us page 
sharing the bakery’s 
story. 

o Menu page listing 
products. 

o Contact page with a 
form and location 
details. 

o Blog for sharing 
recipes and updates. 

o SEO optimization 
and security 
measures. 
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MODULE 1: FOUNDATIONS & PLANNING  

Lesson 1: Introduction to WordPress & Web 
Design Basics 

What is WordPress? 

→ WordPress is a popular website building platform.  

→ It’s user-friendly, even for beginners.  

→ WordPress is a Content Management System (CMS), enabling you to create and 

manage website content without coding.  

→ Example: You can easily write blog posts, add pictures, and create pages.  

Understanding Domains, Hosting, and DNS  

 

→  A domain is your website's address. Example: 

yourwebsite.com.  

→  Hosting is where your website's files are stored on a server, 

making them accessible online.  

→  DNS, or Domain Name System, connects your domain name 

to your hosting server's IP address. Think of  it as a phonebook 

for the internet.  

→  A domain is like your house’s address, hosting is the land it sits 

on, and DNS (the post office) ensures mail reaches the right 

place. 

 

Figure 2: Domain, hosting and DNS 

Figure 1: Understanding domains 
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Basic web design principles (layout, color, 
typography).  

→ Keep your website design simple and clean.  

→ Use clear, readable fonts.  

→ Choose a consistent color palette that reflects your brand.  

→ Ensure your website is responsive, meaning it looks good on all devices 

(phones, tablets, computers). Most WordPress themes include responsive 

design tools, ensuring your site looks great on all devices. 

Planning your website (purpose, target audience, 
content).  

→ Clearly define the purpose of  your website.  

→ Identify your target audience.  

→ Plan the content you will need (text, images, videos).  

→ Example: A bakery website needs high-quality images of  cakes, location 

information, and contact details. 

 

Lesson 2: Domain Name & Hosting Essentials  

A domain is the web address (like www.example.com) that people type into their 

browser to visit your website. No two or more people or businesses can have the 

same domain. This avoids confusion just like no two places can have the same 

address.  

Top Level Domains (TLDs)  

A Top-Level Domain (TLD) is the very last part of  a website address, the letters 

that come after the final dot. The TLD acts like a category or label, telling you 

and the internet what kind of  site it is or where it is located. 

Examples of  TLDs: 

• .com (for commercial use) 

• .org (for organizations) 
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• .edu (for educational institutions) 

• .ca (for Canada) 

• .tech (for technology-focused sites) e.t.c 

Note: Your domain name can only have one TLD. If  you want the same 

name with a different TLD, you must search for and register it separately. 

 

Choosing a domain name (tips, tools).  

→ Keep it short, memorable, and easy to spell.  

E.g. mybakery.com my-amazing-bakery-on-main_street.com 

→ Use relevant keywords if  possible.  

E.g. mybakery.com my-awesome-business.com 

→ Check for domain name availability. (If  the domain name is not available, it 

means that someone has already registered that name. Make some changes 

and check for availability again. 

 

Domain registration (registrar options).  

Domain registration is necessary to secure ownership of your website’s unique 

address, ensuring that no one else can claim it. 

→ Register your domain for at least one year to ensure ownership.  

→ Enable WHOIS privacy to protect your personal information from public 

display. 

→ Use a reputable domain registrar like GoDaddy, Hostinger, Namecheap 

or Ionos. 

→ Go to the domain registrar’s website. Most registrars will allow you to 

search for domain availability without creating an account.  
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Figure 3: Domain Registration on GoDaddy 

 

→ Type your chosen domain name and search for availability 

→ Your desired domain may not always be available. Most registrars will 

suggest alternatives including on different TLDs. 

 

 

Figure 4: Domain Not Available on GoDaddy 

 

→ Go with the suggested alternative or type in a different domain name and 

search again. Repeat until you find a desired domain that is not taken.  
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NOTE: Once a domain is taken, all domain registrars will show that it is 

unavailable, so you do not need to check with a different registrar for the same 

name. 

 

Figure 5: Domain Available for Registration on GoDaddy 

 

Once you have found your desired domain, 

 

→ Read the fine print. Some registrars 

may offer a small amount for the first year in 

a contract but bump it up for the remaining 

years. Others may offer a flat rate. Feel free 

to shop around. 

→ Pay to register your domain once you 

are comfortable with the price and terms. 

→ Note that you can pay your domain 

forward for many years.  

→ You can transfer a domain between 

registrars. Some registrars will lock this 

 

Figure 6: Domain Registration fine print 
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Understanding web hosting (shared, VPS, dedicated).  

Web hosting is a service that provides the server space and technology needed 

to build your website (store your WordPress site’s files), connect it to your 

registered domain and make it accessible online. 

 

→ Shared hosting is affordable and suitable for beginners. 

Multiple websites share the same server resources. 

→ VPS, or Virtual Private Server, hosting offers more 

resources and control. It's like having your own dedicated 

portion of  a server.  

→ Dedicated hosting provides an entire server for your 

website, offering maximum performance and control. 

 

 

Selecting a hosting provider (key features  and 
considerations).  

→ Look for costs within your budget 

→ Look for reliable customer support.  

→ Check for fast server speeds and uptime guarantees.  

→ Ensure they offer simple WordPress installation.  

→ Examples of  hosting providers include Bluehost, Ionos, and Hostinger. 

 

Setting up your hosting account.  

→ Go to the host’s website and create an account 

→ Keep your login credentials secure. 

→ Select your desired hosting plan and follow the hosting provider's setup 

instructions. 

Figure 7: Illustration of a server 
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→ Access your hosting control panel (hosting control panel or similar). 

→ Connect your domain. We will use Hostinger but the process is very similar 

for other registrars) 

 

Connecting your domain has two main parts: Getting the Name Servers from 

your host and pasting them at Your Domain Registrar. 

Part 1: Get the Hostinger "Directions" 

1. Log in to your Hostinger Account (the company where you bought your 

website hosting plan). 

2. Go to your hosting management area (often called the hPanel or the 

Dashboard). 

3. Look for a section related to your Website or Hosting Plan Details. 

4. Find the special addresses called Nameservers (or NS records). They 

usually come in a pair and look like this (but use the exact ones Hostinger 

gives you): 

o ns1.hostinger.com 

o ns2.hostinger.com 
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5. Copy these two nameserver addresses and keep this window open, you'll 

need them in the next step! 

 

Part 2: Tell Your Domain Where to Go 

1. Log in to your Domain Registrar Account (the company where you 

bought your domain name, like GoDaddy, Namecheap, etc.). 

2. Find the list of  your domains and click on Manage for the domain you 

want to connect. 
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3. Look for a setting called Nameservers, DNS, DNS Management, or 

Change Name Servers. 

 

 

4. You will likely see some default nameservers from your domain company. 

You need to replace them. 

o Choose the option for Custom Nameservers (or similar). 

o In the first box, paste the first Hostinger address (e.g., 

ns1.hostinger.com). 

o In the second box, paste the second Hostinger address (e.g., 

ns2.hostinger.com). 

5. Save the changes. You might have to click a "Save" or "Apply" button. 

 

Part 3: Wait a Little Bit (The "Propagation" Period) 

• The change is not instant. It takes time for all the computers and networks 

around the world to update with your domain's new address. This process is 

called DNS Propagation. 

• It typically takes a few hours, but your hosting company will usually tell you 

to wait up to 24 hours (sometimes up to 48 hours) for the connection to 

be complete. 

• During this time, your website might be temporarily unavailable, or you 

might see the old page or a parking page. Just be patient! 

• Once it's done, your domain will successfully load the website you've set up 

on Hostinger. 

ns1.hostinger.com 

ns2.hostinger.com 
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Research 2 Domain Names and compare prices from 2 registrars.   

• Brainstorm 2 potential domain names for a website based on a 

topic you like (e.g., a local bakery, a personal blog about 

hobbies, a small online store). 

• Research 2 different registrars and 2 hosting providers, noting 

down the basic shared hosting plan cost, storage offered, and 

whether they offer one-click WordPress installation. 
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MODULE 1: QUIZ 

 

 

 

 

1. What is the primary purpose of a Content Management System (CMS) like WordPress?  

☐ a) To write and edit code for websites.  

☐ b) To create and manage website content easily without extensive coding. 

☐ c) To design complex website graphics and animations.  

☐ d) To manage a website's server and hosting configurations. 
  
2. Which of the following best describes a domain name?  

☐ a) The physical server where a website's files are stored.  

☐ b) The software used to build and manage a website.  

☐ c) The unique web address that visitors type to access a website.  

☐ d) The system that translates domain names into IP addresses.  
 

3. What is web hosting? 

☐ a) The process of registering a domain name.  

☐ b) The service of storing your website's files on a server so they can be accessed online.  

☐ c) The design and layout of a website's pages.  

☐ d) The optimization of a website for search engines.  
 

4. What is the role of DNS (Domain Name System)?  

☐ a) To design the visual appearance of a website.  

☐ b) To store website files and databases.  

☐ c) To connect domain names to the IP addresses of web servers.  

☐ d) To manage the content and functionality of a website.  
 

5. When planning your website, what is the first and most crucial question to consider?  

☐ a) What color scheme should I use?  

☐ b) What is the purpose of my website? 

☐ c) Which hosting provider should I choose?  

☐ d) What plugins will I need? 

 

 

 

Learner’s Name: ______________________________________  

Batch: ___________________ Month: ___________Year _____ 
Link 1: Scan to take 
interactive quiz online 

https://sntechpros.com/quiz-answers
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Hands-on Project Planning  

Goal: Plan the Awesome Bakery website’s structure, content, and technical requirements.  

Tasks: 

1. Define the Website’s Purpose and Audience: 

o Write a one-sentence purpose statement: “The Awesome Bakery website will 

promote our baked goods, share our story, and connect with local customers.”  

o Identify the target audience: Local customers, families, and event planners seeking 

quality baked goods. 

2. Plan Content: 

o List content needs: 

▪ Homepage: Banner image, welcome text, and featured products.  

▪ About Us: Story of  the bakery and a photo. 

▪ Menu: List of  products with images and descriptions. 

▪ Contact: Address, phone, email, and a contact form. 

▪ Blog: At least one post (e.g., “Our Favorite Cake Recipe”).  

o Gather assets: Collect sample images (e.g., cakes, bakery interior) and write draft 

text for each page. 

3. Choose a Domain and Hosting: 

o Select a domain name: awesomebakery.com (check availability using Namecheap or 

GoDaddy). 

o Choose a hosting provider: Opt for a beginner-friendly provider like Bluehost or 

Hostinger with one-click WordPress installation. 

o Register the domain and set up hosting, ensuring WHOIS privacy is enabled.  

Deliverable: A written plan (use a provided template) outlining the website’s purpose, audience, 

content, and domain/hosting choices. 
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MODULE 2: WORDPRESS INSTALLATION & 
SETUP 
 

Lesson 3: Installing WordPress 

Think of  your hosting as the land you bought and your domain as the address. 

Now, you need to build a house (your website) on that land. WordPress is like a 

pre-fabricated house kit that's simple to assemble. This lesson provides detailed 

step-by-step instructions for installing WordPress using both one-click and 

manual methods, ensuring beginners can follow along confidently. 

 

One-click installation via hosting control panel.  

Most hosting providers offer a straightforward one-click WordPress installation, 

making it the easiest option for beginners. Tools like Softaculous or similar 

automate the process, requiring minimal input. 

Step-by-Step Instructions: 

1. Log in to Your Hosting Account: 

o Access your hosting provider’s control panel (e.g., cPanel for 

Bluehost or Hostinger’s hPanel). 

o Use the login credentials provided when you signed up for hosting.  

o Example: Visit yourhostingprovider.com and click “Login” or “Client 

Area.” 

2. Locate the WordPress Installer: 

o In the control panel, look for a section labeled “WordPress,” “One-

Click Installs,” “Softaculous,” or “Website Builder.” 

o Click the WordPress icon to start the installation process. 

o Create WordPress Login Credentials. Installing WordPress on 

Hostinger shows the following interface. 
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Figure 8: Installing WordPress on Hostinger 

3. Start the Installation: 

o Click “Install Now” or “Quick Install.” 

Hostinger or some other hosts may show additional options during installation 

such as below. 

 



 
19 | P a g e  

 
 

o You’ll be prompted to fill out a form with basic details:  

▪ Choose Protocol: Select https:// if  you have an SSL 

certificate (recommended for security). 

▪ Choose Domain: Select your domain (e.g., yourwebsite.com) 

from the dropdown. 

▪ Site Name: Enter a name for your site (e.g., “My Bakery”). 

▪ Site Description: Add a brief  tagline (e.g., “Freshly Baked 

Goods Daily”). 

▪ Admin Username: Choose a unique username (avoid “admin” 

for security). 

▪ Admin Password: Create a strong password (e.g., mix letters, 

numbers, and symbols like B@k3ry2025!42311). 

▪ Admin Email: Enter your email for notifications. 

o Example: For a bakery site, you might enter “Awesome Bakery” as 

the site name and “info@awesomebakery.com” as the admin email.  

4. Complete the Installation: 

o Click “Install” or “Submit.” 

o Wait for the installer to set up WordPress (usually takes 1–2 minutes). 

o You’ll receive a confirmation with your admin login URL (e.g., 

yourwebsite.com/wp-admin) and credentials. 

o Save these details securely. 

5. Test the Installation: 

o Visit yourwebsite.com to see your new WordPress site (it will use a 

default theme initially). 

o Log in to the dashboard at yourwebsite.com/wp-admin using your 

admin username and password. Many hosts give a one click route to 

log in to your WordPress Dashboard. 
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Troubleshooting Tips: 

• If  the installation fails, check that your domain is correctly pointed to your 

hosting provider’s nameservers (contact host support if  unsure). 

• If  you see a “database error,” ensure your hosting plan includes a database 

and retry the installation. 

 

→ Most hosting providers offer a straightforward one-click WordPress 

installation.  

→ How it works: Your hosting company has tools (often called "Softaculous" 

or similar) that automate the process. Enter basic details (site name, admin 

username, password), and the tool completes the installation. 

 

→ Practical Example: Log in to your hosting account (e.g., through hosting 

control panel). Look for an icon or section labeled "WordPress," "One-

Click Installs," or "Software." Click on it, follow the on-screen instructions, 

and provide the necessary information. 

 

 

Manual installation via FTP (if applicable).  

→ This is like building your house from individual parts. It gives you more 

control but requires a bit more technical know-how.  

→ Scenario: You might need to do this if  your hosting provider doesn't offer 

one-click installation or if  you have specific advanced requirements.  

→ Steps (Simplified Analogy):  

1. Download the House Plans (WordPress Files): You download the latest 

WordPress files from WordPress.org/download. 

- Save the file to your computer and extract it to a folder (e.g., 

wordpress). 

2. Prepare Your Land (Create a Database): You use your hosting control 

panel to create a database for WordPress to store its information. Think of  

this as laying the foundation. 

https://wordpress.org/
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• Log in to your hosting control panel. 

• Find the “Databases” section and select “MySQL Databases” or 

similar. 

• Create a new database (e.g., “wp_database”). 

• Create a database user (e.g., “wp_user”) with a strong password. 

• Link the user to the database with full privileges. 

• Note down the database name, username, and password (e.g., 

Database: wp_database, User: wp_user, Password: DbP@ss2025!). 
 

3. Transfer the Parts (Upload Files via FTP): You use an FTP program 

(like FileZilla) to upload the WordPress files to your hosting server. This is 

like bringing all the building materials to your land. 

• Download an FTP client like FileZilla (free at filezilla-project.org). 

• Connect to your hosting server using your FTP credentials (provided 

by your host, e.g., Host: ftp.yourwebsite.com, Username: ftp_user, 

Password: FtpP@ss2025!). 

• Navigate to your website’s root directory (usually public_html or 

www). 

• Upload the contents of the extracted WordPress folder to this 

directory. 

4. Follow the Setup Wizard (Run the Installation Script): You visit your 

website's domain in a web browser, and WordPress will guide you through 

the final steps of  setting up your "house." 

o Open your browser and visit yourwebsite.com. 

o WordPress will detect the uploaded files and start the setup wizard.  

o Select your language and click “Continue.” 

o Enter your database details from Step 2: 

▪ Database Name: wp_database 

▪ Username: wp_user 

▪ Password: DbP@ss2025! 

▪ Database Host: Usually localhost (check with your host if  

unsure). 
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▪ Table Prefix: Leave as wp_ or customize for security. 

o Click “Submit” and then “Run the Installation.” 

2. Complete the Setup: 

o Enter site details: 

▪ Site Title: E.g., “Awesome Bakery.” 

▪ Username: Choose a unique admin username. 

▪ Password: Create a strong password. 

▪ Your Email: For admin notifications. 

▪ Search Engine Visibility: Check “Discourage search engines” 

if  you’re not ready to launch. 

o Click “Install WordPress.” 

o You’ll see a success message with your admin login URL 

(yourwebsite.com/wp-admin). 

3. Test and Log In: 

o Visit yourwebsite.com to confirm the site loads. 

o Log in to the dashboard at yourwebsite.com/wp-admin to start 

managing your site. 

Troubleshooting Tips: 

• If  you get a “connection refused” error, verify your FTP credentials or 

contact your host. 

• For database errors, double-check your database name, username, and 

password in the wp-config.php file (created during setup). 

 

 

Navigating the WordPress dashboard.  

Once installed, you access your WordPress backend (the dashboard) by going to 

www.yourwebsite.com/wp-admin and entering the credentials that you set when 

you installed WordPress. 
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Analogy: The dashboard is your website’s control panel, like the central hub of  a 

house. From here, you can manage everything: add plugins (like furniture), change 

themes (like decor), create posts (like diary entries), and organize pages (like 

rooms). 

Key Areas:  

o Dashboard: An overview of  your site's activity. 

o Posts: Where you create and manage blog articles. 

o Media: Your library for images, videos, and other files. 

o Pages: For static content like "About Us" or "Contact" 

o Comments: Where you manage visitor feedback. 

o Appearance: For customizing your site's look (themes, widgets, 

menus). 

o Plugins: For adding extra features to your site. 

o Users: For managing website administrators and other users. 

o Tools: For importing, exporting, and site health checks. 

o Settings: For configuring various aspects of  your WordPress site. 
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Figure 9: Understanding the WordPress Dashboard 

Basic Settings Configuration (Initial Housekeeping)  

After installation, configure basic settings to prepare your site:  

• Go to Settings > General to set your site title, tagline, and time zone. 

• Example: For a bakery, set Site Title to “Awesome Bakery” and Tagline to 

“Freshly Baked Goods Daily.” 

• Save your changes to ensure your site reflects your brand. 

 

 

Lesson 4: WordPress Core Configuration 

General settings (site title, tagline, time zone).  

Access these options under Settings > General. 
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Site Title: The name of  your website (e.g., "Awesome Bakery"). Think of  it as 

the sign above your shop.  

→ Tagline: A short description of  your site (e.g., "Freshly Baked Goods 

Daily"). Like a catchy slogan.  

→ WordPress Address (URL): Where your WordPress core files are located. 

Usually, you don't need to change this.  

→ Site Address (URL): The address people type to visit your website. 

Usually the same as the WordPress Address.  

→ Email Address: The main administrative email for your site. Important for 

notifications.  

→ Membership: Decide if  you want to allow user registrations (e.g., for a 

membership site).  

→ New User Default Role: If  you allow registration, what role new users will 

have (e.g., Subscriber).  

→ Time zone: Set your local time zone for accurate post scheduling and date 

display.  

→ Date Format & Time Format: Choose how dates and times are displayed 

on your site. 

 

 

Figure 10: WordPress General Settings 
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Reading settings (homepage display, blog settings).  

Found under Settings > Reading. 

→ Your homepage displays: Choose whether your homepage shows your 

latest blog posts or a static page you've created.  

o Latest posts: Ideal for a blog. Think of  it as the front page of  a 

newspaper, constantly updating. 

o A static page: Good for business websites. You can select specific 

pages for your Homepage and Posts page. 

→ Blog pages show at most: Control how many blog posts appear on each 

page of  your blog archive. 

→ Syndication feeds: Configure how your content is shared via RSS feeds. 

→ Search Engine Visibility: Uncheck ‘Discourage search engines from indexing this 

site’ under Settings > Reading when ready to launch, allowing Google and other 
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search engines to index your site.

 

Figure 11: WordPress reading settings 

 

Permalink settings (SEO-friendly URLs).  

Found under Settings > Permalinks.  

→ Analogy: Permalinks are like the permanent addresses of  individual pages 

and posts on your website. You want them to be clear and straightforward.  

→ Best Practice: Choose "Post name" (e.g., yourdomain.com/your-blog-

post-title/). This is SEO-friendly and readable. Avoid the "Plain" option as 

it's not user-friendly or good for SEO. 
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Figure 12: WordPress permalink settings 

 

User management (creating users, roles).  

Found under Users > All Users and Users > Add New. 

→ User Roles: WordPress has different user roles with varying levels of  

permissions:  

o Administrator: Full control over the entire site. 

o Editor: Can manage posts, pages, comments, categories, and tags of  

all users. 

o Author: Can write, edit, and publish their own posts. 

o Contributor: Can write and manage their own posts but cannot 

publish them. 

o Subscriber: Can only manage their profile and leave comments. 

    

Scenario: If  you have a team working on your website, you'll create user accounts 

for them and assign appropriate roles based on their responsibilities. For example, 

a writer would likely be an "Author" or "Contributor." 
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Figure 13: Adding a website user 

 

→ By the end of  this module, learners should have a fully installed and 

configured WordPress website, ready for customization and content 

creation.  

 

 

 

  Task: Navigate the WordPress Dashboard and Adjust Basic Settings.  

• Log in to their practice WordPress installation. 

• Change the "Site Title" and "Tagline" under Settings > General. 

• Navigate to Settings > Permalinks and select the "Post name" option, 

saving their changes. 
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MODULE 2: QUIZ 

 

 

 

 

 

 
1. Which is generally considered the easiest way to install WordPress for beginners?  

☐ a) Manual installation via FTP.  

☐ b) Using the command line interface.  

☐ c) One-click installation through the hosting control panel.  

☐ d) Installing directly from the WordPress.org website. 
  

2. After installing WordPress, how do you typically access the administrative 
dashboard?  

☐ a) By visiting yourdomain.com/admin/  

☐ b) By visiting yourdomain.com/login/  

☐ c) By visiting yourdomain.com/wp-admin/  

☐ d) By visiting yourdomain.com/dashboard/ 
  

3. In WordPress settings, what is the primary purpose of  configuring permalinks?  

☐ a) To manage user permissions and roles.  

☐ b) To set the visual theme and design of  the website.  

☐ c) To define the structure and appearance of  your website's URLs.  

☐ d) To control how your homepage displays content.  
 

4. Under WordPress General Settings, what is the "Tagline"?  

☐ a) The main navigation menu of  your website.  

☐ b) A short descriptive phrase for your website.  

☐ c) The legal terms and conditions of  your website. 

☐ d) The primary contact email address for your website. 
  

5. In WordPress, what is the significance of  the "Search Engine Visibility" setting 
under Reading?  

☐ a) It controls how many blog posts are displayed on a single page.  

☐ b) It allows you to choose whether your homepage displays latest posts or a static page.  

☐ c) It determines whether search engines are allowed to index your website.  

☐ d) It configures the format for dates and times displayed on your site.  

Learner’s Name: ______________________________________  

Batch: ___________________ Month: ___________Year _____ 

Link 2: Scan to take 
interactive quiz online 

https://sntechpros.com/quiz-answers
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Hands-on Project: WordPress Installation & Setup  

 

Goal: Install and configure WordPress to create the foundation for Awesome Bakery’s website.  

Tasks: 

1. Install WordPress: 

o Use the one-click installer in your hosting control panel (e.g., Bluehost’s cPanel or 
Hostinger’s hPanel). 

o Steps: 

▪ Log in to your hosting account. 

▪ Navigate to “WordPress” or “Softaculous” in the control panel.  

▪ Select https:// and awesomebakery.com as the domain. 

▪ Enter: 

▪ Site Name: “Awesome Bakery” 

▪ Site Description: “Freshly Baked Goods Daily” 

▪ Admin Username: A unique name (e.g., “bakeryadmin”) 

▪ Admin Password: A strong password (e.g., B@k3ry2025!) 

▪ Admin Email: Your email (e.g., info@awesomebakery.com) 

▪ Click “Install” and note the admin URL (awesomebakery.com/wp-admin). 

o Reference Figure 5: Installing WordPress on Hostinger . 

2. Configure Basic Settings: 

o Log in to the WordPress dashboard at awesomebakery.com/wp-admin. 

o Go to Settings > General: 

▪ Set Site Title: “Awesome Bakery” 

▪ Set Tagline: “Freshly Baked Goods Daily” 

▪ Set Time Zone: Your local time zone (e.g., UTC-5 for Eastern Time). 

o Go to Settings > Permalinks: 

▪ Select “Post name” for SEO-friendly URLs (e.g., awesomebakery.com/about-
us). 

o Go to Settings > Reading: 

▪ Set “Your homepage displays” to “A static page” and select a placeholder 
Homepage (to be created later). 

Deliverable: A fully installed and configured WordPress site accessible at awesomebakery.com. 
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MODULE 3: THEMES & CUSTOMIZATION  
 

Lesson 5: Understanding WordPress Themes 

What are themes? (structure, functionality).  

Themes control your website's look and feel. They handle design and layout.  

 

Free vs. premium themes.  

→ Free Themes: Available in the WordPress theme directory with basic 

features and limited support.  

→ Premium: Purchased from third-party providers. Often offer more 

features, customization options, and support. 

 

Choosing a theme (factors to consider).  

→ Consider your website's purpose and brand.  

→ Look for responsive designs (works on all devices).  

→ Check user reviews and ratings.  

→ Ensure it's regularly updated. 

→ Preview the theme before installing to check its design and suitability.  

 

Installing and activating a theme.  

→ From WordPress Directory: Go to Appearance > Themes > Add New. 

Type “Astra” in the search bar, click ‘Install’ then ‘Activate’. You can 

preview a theme before installing it  

→ Uploading a Theme: If  you have a premium theme file (.zip), go to 

Appearance > Themes > Add New > Upload Theme. Upload the file 

from your computer or cloud storage and then "Activate." 
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Figure 14: Choosing, adding a WordPress Theme 

 

Lesson 6: Customizing Your Theme  

Customization lets you tailor the theme’s appearance and functionality to your 

preferences. 

 

Using the WordPress Customizer.  

Go to Appearance > Customize. This allows you to visually adjust many theme 

settings. 

Understanding theme options.  

→ Different themes have different customization options (colors, fonts, 

layouts, logos). Explore the available settings in the Customizer.  

Basic CSS Customization (Quick Overview)  

CSS (Cascading Style Sheets) controls the visual styling of  your website. You can 

add custom CSS in the Customizer (Appearance > Customize > Additional 

CSS) for more specific changes. Example: To change the color of  your headings. 

CSS allows extensive styling options, such as adjusting fonts, colors, and layouts. 
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Creating a website menu on WordPress. 

A website menu is like a map or guide that helps visitors easily find different 

pages or sections on your site. On a WordPress website, the menu is usually found 

at the top of  the page (called the “navigation bar”) or sometimes in the footer or 

side. 

For example, if  your website is about a bakery, your menu might have items like:  

• Home – goes back to your homepage 

• About Us – tells people who you are 

• Menu – shows the baked goods you sell 

• Contact – lets people reach you 

In WordPress, you can create and organize menus easily by going to: 

Dashboard → Appearance → Menus → Add New 

Next, 

→ Give your menu a name.  

→ Select the pages, posts or links you want to add to the menu  

→ Choose a menu location (usually "Primary Menu").  

→ Click "Save Menu." 
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Figure 15: Creating a website Menu on WordPress 

 

Lesson 7: Pages and Posts  

In WordPress, pages and posts are two main ways to add content: 

• Pages are for static content like Home, About Us, or Contact. They don’t 

change often. 

• Posts are for blog-style updates. They show up by date and can be grouped 

with categories or tags. 

Think of  pages as permanent parts of  your site and posts as timely news or 

articles. 

 

Creating pages (About, Contact, Services).  

To create a page, go to Pages > Add Page.  

• Give your page a title (e.g., “About Us”) and write your content using the 

block editor. You can add text, images, buttons, and more. 

• On the right sidebar, you can:  
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o Assign a parent page (to create page hierarchies like “Services > 

Web Design”), 

o Choose a template if  your theme offers layout options. 

• Once you're happy with your content, click “Publish” to make the page 

live. 

• You can then add this page to your site's menu for easy navigation. 

 

 

Figure 16: Adding a page to your WordPress website 

Creating blog posts.  

To create a blog post, go to Posts > Add New. 

1. Add a title (e.g., “Our Latest Project”) and use the block editor to insert 

text, images, videos, or anything else. 

2. On the right sidebar, you can: 

o Assign a category (like News or Tips), 

o Add tags to help readers find related posts, 

o Set a featured image to appear with your post. 

3. Click “Publish” to make your post visible on your site. 



 
37 | P a g e  

 
 

Posts are usually shown on your blog page or homepage, depending on your 

settings. 

 

 

Figure 17: Adding blog posts 

 

Using the block editor (Gutenberg).  

WordPress uses a block-based editor. Each piece of  content (text, image, heading) 

is a separate block. Click the "+" icon to add new blocks or type “/” to choose a 

block. 

 

 

Figure 18: Using the block editor on WordPress 
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Media management (images, videos, Documents). 

Media refers to the files you upload to your site like images, videos, PDFs, or 

audio. These help bring your content to life. 

To add media: 

1. Go to Media > Add New in your WordPress dashboard. 
2. Click “Select Files” to upload from your computer, or drag and drop 

them. 
3. Once uploaded, files appear in your Media Library, where you can view, 

edit, or use them anytime. 
You can also add media directly while editing a page or post by clicking the “Add 

Media” or “Image/Video” block in the block editor. 

 

Figure 19: Adding website media 

  

Task: Install and Customize a Free Theme.  

• Go to Appearance > Themes > Add New and install a popular 

free theme e.g., Astra, OceanWP, Neve 

• Once activated, to go to Appearance > Customize and try 

changing the site's color scheme and upload a sample logo. 
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MODULE 3: QUIZ 

 

 

 

 

 

 
1. What is the main function of  a WordPress theme?  

☐ a) To add new features and functionality to your website.  

☐ b) To manage your website's content and media files.  

☐ c) To control the visual design and layout of  your website.  

☐ d) To optimize your website for search engines. 
 
2. Where can you typically find and install free WordPress themes?  

☐ a) By downloading them directly from individual developer websites.  

☐ b) Through the WordPress dashboard under Appearance > Themes > Add New.  

☐ c) By purchasing them from online marketplaces and uploading the files.  

☐ d) All of  the above. 
 
3. What is the WordPress Customizer primarily used for? 

☐ a) Writing and editing blog posts.  

☐ b) Managing user accounts and permissions.  

☐ c) Visually adjusting various aspects of  your active theme.  

☐ d) Installing and activating plugins.  
 
4. What is CSS (Cascading Style Sheets) primarily responsible for in WordPress?  

☐ a) The content and structure of  your website pages.  

☐ b) The interactive elements and dynamic functionality of  your website.  

☐ c) The visual styling and presentation of  your website.  

☐ d) The organization and storage of  your website's data.  
 
5. Where do you typically create and manage the main navigation menu of  your 
WordPress website?  

☐ a) Appearance > Themes  

☐ b) Appearance > Customize  

☐ c) Appearance > Menus  

☐ d) Settings > Navigation 
  

Learner’s Name: ______________________________________  

Batch: ___________________ Month: ___________Year _____ 

Link 3: Scan to take 
interactive quiz online 

https://sntechpros.com/quiz-answers
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Hands-on Project: Themes & Customization  
Goal: Customize the website’s appearance to reflect Awesome Bakery’s brand.  
Tasks: 
1. Choose and Install a Theme: 

o Go to Appearance > Themes > Add New . 

o Search for a free, responsive theme like “Astra” or “Neve” (suitable for a bakery with clean, professional designs).  

o Click “Install” and then “Activate.” 

o Preview the theme to ensure it suits the bakery’s aesthetic (e.g., warm colors, image -focused layout). 

o Reference Figure 11: Choosing, adding a WordPress Theme . 
2. Customize the Theme: 

o Go to Appearance > Customize. 

o Adjust settings: 

▪ Site Identity: Upload a logo (e.g., a bakery emblem) and confirm the Site Title and Tagline.  

▪ Colors: Choose a warm color palette (e.g., cream, brown, and soft pink to reflect baked goods).  

▪ Typography: Select a readable font like “Open Sans” for body text and “Lobster” for headings.  

▪ Header: Add a banner image of a bakery display (use a royalty-free image from Unsplash). 

o Save and publish changes. 
3. Create a Navigation Menu: 

o Go to Appearance > Menus > Create a New Menu . 

o Name the menu “Primary Menu.” 

o Add pages (to be created): “Home,” “About Us,” “Menu,” “Contact,” and “Blog.”  

o Set the menu location to “Primary Menu” and click “Save Menu.”  

o Reference Figure 12: Creating a website Menu on WordPress . 
4. Create Key Pages and a Blog Post: 

o Homepage: 

▪ Go to Pages > Add New. 

▪ Title: “Home.” 

▪ Use the block editor to add: 

▪ A heading block: “Welcome to Awesome Bakery!”  

▪ A paragraph block: “Discover our delicious cakes, pastries, and breads, baked fresh daily.”  

▪ An image block: Upload a bakery banner image. 

▪ A button block: “View Our Menu” linking to the Menu page.  

▪ Publish and set as the homepage in Settings > Reading. 

o About Us Page: 

▪ Go to Pages > Add New. 

▪ Title: “About Us.” 

▪ Add text: “Awesome Bakery has been serving our community since 2020, with a passion for quality ingredients.”  

▪ Add an image of the bakery or team. 

▪ Publish. 

o Menu Page: 

▪ Title: “Menu.” 

▪ Add a heading: “Our Baked Goods.” 

▪ Use a columns block to list products (e.g., “Chocolate Cake - $25,” “Sourdough Bread - $5”). 

▪ Add images for each product. 

▪ Publish. 

o Contact Page: 

▪ Title: “Contact.” 

▪ Add text: “Visit us at 123 Main St, City, or call (555) 123-4567.” 

▪ Add a placeholder for a contact form (to be added in Module 4).  

▪ Publish. 

o Blog Post: 

▪ Go to Posts > Add New. 

▪ Title: “Our Favorite Cake Recipe.” 

▪ Add text and an image of a cake. 

▪ Assign a category (e.g., “Recipes”) and tags (e.g., “cake,” “baking”).  

▪ Publish. 

o Reference Figures 13–15: Adding pages, posts, and using the block editor . 
Deliverable: A customized WordPress site with a branded theme, navigation menu, and essential pages/posts.  
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MODULE 4: PLUGINS & FUNCTIONALITY  
In this module, we'll explore the power of  WordPress plugins. Plugins are like 

apps for your website, allowing you to easily add new features and extend its 

capabilities without needing to write any code. Get ready to unlock a whole new 

level of  functionality for your WordPress site! 

 

Lesson 8: Essential WordPress Plugins 

Let’s cover some fundamental plugins that almost every website needs to function 

effectively and professionally. 

 

What are plugins? (extending functionality).  

Plugins are software tools you can download from the WordPress plugin library or 

upload and install on your site. They add new features or modify existing ones. 

Think of  them as apps on your smartphone. 

 

Installing and activating plugins.  

→ Go to Plugins > Add New.  

→ You can search for plugins in the WordPress repository.  

→ Click "Install Now" and then "Activate."  

→ If  you have a plugin file (.zip), click "Upload Plugin" and follow the 

prompts. 
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Figure 20: Adding plugins 

 

Essential plugins  

SEO Plugins  

These help your website rank higher in search engine results like Google and Bing.  

• Examples: Examples: Yoast SEO, All in One SEO, or Rank Math. These 

plugins help you optimize your content with keywords, generate sitemaps, 

and improve overall SEO health. 
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Figure 21: Popular SEO plugins 

 

Security (Wordfence, Sucuri).  

These protect your website from attacks and 

malware.  

• Example: Wordfence or Sucuri Security. 

These plugins offer firewalls, malware scanning, 

and login protection. 

 

Contact forms (Contact Form 7, 
WPForms).  

These allow visitors to easily contact you.  

• Example: Contact Form 7, Calculated 

Fields Forms or WPForms. These plugins let 

you create customizable contact forms and 

embed them on your pages. 

 

 

 

Figure 22: Wordfence security plugin 

Figure 23: Contact Form 7 plugin 
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Page Builders (Elementor, Beaver Builder).  

While we'll cover these in more detail next, 

some essential plugins fall into this category, 

allowing for drag-and-drop website design.  

• Example: Elementor (free version) or 

Beaver Builder (free version). These provide 

visual interfaces for building page layouts. 

 

 

 

Lesson 9: Page Builders and Advanced Design  

Introduction to page builder plugins.  

Now that you know about essential plugins, let's dive deeper into page builders. 

These powerful tools revolutionize how you design your website layouts. 

• Introduction to Page Builder Plugins: Page builders are plugins that 

allow you to create complex and visually appealing page layouts using a 

drag-and-drop interface. You don't need to know code to design 

professional-looking pages. 

 

Drag and drop website design.  

Page builders simplify building complex layouts, allowing you to drag and drop 

elements like text, images, and buttons, bypassing the WordPress block editor.  

Creating custom page layouts.  

With page builders, you can easily create unique layouts with multiple columns, sections, and 

custom styling that go beyond the standard WordPress block editor capabilities.  

• Scenario: Want a homepage with a large banner image, two columns of  text and 

images, and a call-to-action button? A drag and drop page builder can be used to design 

it visually. 

 

Figure 24: Elementor page builder 
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Responsive design principles.  

Most good page builders ensure your designs are responsive, meaning they 

automatically adjust to look great on different screen sizes (desktops, tablets, and 

mobile phones). You often have specific settings to fine-tune how your layout 

appears on different devices. 

 

Lesson 10: E-commerce Basics (Introduction)  

For those interested in selling products or services online, WordPress offers 

powerful e-commerce plugins. This lesson provides a basic introduction to get 

you started. 

Introduction to WooCommerce.  

WooCommerce is the most popular e-commerce 

plugin for WordPress. It adds all the necessary 

features to turn your website into an online 

store. Install and activate the WooCommerce 

plugin via Plugins > Add New. 

Setting up a basic online store.  

Installing and activating WooCommerce will 

guide you through a setup wizard where you can 

configure essential store settings like currency, 

shipping options, and payment gateways. 

 

Product listings and payment gateways.  

You'll learn how to add product information, including titles, descriptions, images, 

pricing, and inventory management within WooCommerce. 

 

Payment Gateways (Overview)  

To accept payments online, you need to integrate a payment gateway (like PayPal 

or Stripe) with WooCommerce. 

Figure 25: WooCommerce Plugin 
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We'll briefly touch on how these 

gateways work and the options 

available. (Our full e-commerce 

course dives much deeper into 

this). 

 

 

 

 

  Task: Install and Activate an Essential Plugin.  

• Go to Plugins > Add New and search for "Contact Form 7" or 

"WPForms Lite." 

• Install and activate one of  these plugins. 

• Locate the new menu item created by the plugin in the WordPress 

dashboard. 

Figure 26: WooCommerce Paypal Plugin enables payments via PayPal 



 
47 | P a g e  

 
 

MODULE 4: QUIZ 

 

 

 

 

 
1. What is the primary purpose of  a WordPress plugin?  

☐ a) To change the overall design and layout of  your website.  

☐ b) To add new features and extend the functionality of  your WordPress site.  

☐ c) To manage your website's hosting and domain settings.  

☐ d) To optimize your website's images and media files.  
 
2. Where is the main section in the WordPress dashboard to install and manage 
plugins?  

☐ a) Appearance > Plugins  

☐ b) Tools > Plugins  

☐ c) Settings > Plugins  

☐ d) Plugins  
 
3. Which type of  plugin is crucial for helping your website appear in search engine 
results like Google?  

☐ a) Security plugin  

☐ b) Caching plugin  

☐ c) SEO plugin  

☐ d) Backup plugin  
 
4. What is the main benefit of  using a page builder plugin?  

☐ a) It automatically writes content for your website.  

☐ b) It allows you to create complex page layouts visually using drag-and-drop.  

☐ c) It manages all your website's security features. 

☐ d) It automatically translates your website into multiple languages.  
 
5. What is the name of  the most popular e-commerce plugin for WordPress?  

☐ a) Contact Form 7  

☐ b) WooCommerce  

☐ c) Yoast SEO  

☐ d) Elementor 
 
 

 

Learner’s Name: ______________________________________  

Batch: ___________________ Month: ___________Year _____ 

Link 4: Scan to take 

interactive quiz online 

https://sntechpros.com/quiz-answers
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Hands-on Project: Plugins & Functionality  
Goal: Enhance the website with plugins for SEO, security, contact forms, and advanced design.  

Tasks: 

1. Install Essential Plugins: 

o Go to Plugins > Add New. 

o Install and activate: 

▪ Yoast SEO: For search engine optimization. 

▪ Wordfence Security: For site protection. 

▪ WPForms: For a contact form. 

▪ Elementor: For advanced page design (optional for the homepage). 

o Reference Figure 17: Adding plugins. 

2. Configure Yoast SEO: 

o Run the Yoast SEO setup wizard (prompted after activation). 

o Set up basic SEO settings: 

▪ Add a focus keyword for the homepage (e.g., “bakery in [city]”).  

▪ Generate a sitemap for search engines. 

o Optimize the “Menu” page with a meta description: “Explore the delicious cakes, pastries, 

and breads at Awesome Bakery in [city].” 

3. Set Up WPForms for the Contact Page: 

o Go to WPForms > Add New. 

o Create a “Simple Contact Form” with fields: Name, Email, Message.  

o Save and copy the shortcode (e.g., [wpforms id="1"]). 

o Edit the Contact page, add a shortcode block, and paste the shortcode. 

o Test the form by submitting a sample message. 

o Reference Figure 18: Popular plugins (showing WPForms) . 

4. Secure the Site with Wordfence: 

o Run the Wordfence setup wizard. 

o Enable the firewall and scan for malware. 

o Set up login attempt limits to prevent brute-force attacks. 

5. Enhance the Homepage with Elementor (Optional) : 

o Edit the Homepage with Elementor. 

o Drag and drop elements to create a layout with: 

▪ A full-width banner image. 

▪ A two-column section for featured products. 

▪ A call-to-action button linking to the Menu page. 

o Save and publish. 

Deliverable: A website with enhanced functionality, including a contact form, SEO optimization, and 

security measures. 
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MODULE 5: LAUNCH & MAINTENANCE  
Welcome to the final module, Module 5: Launch & Maintenance! You've come a 

long way, from understanding the basics to building a functional website with 

plugins. Now, it's time to prepare your site for the world and learn how to keep it 

running smoothly. 

 

Lesson 11: Website Optimization & Security  

Before you launch, it's crucial to optimize your website for speed and ensure it's 

secure. A fast and secure site provides a better user experience and helps with 

search engine rankings. 

Image optimization.  

Large, unoptimized images can significantly slow down your website. In this 

lesson, you'll learn how to:  

• Resize images: Make sure images are the correct dimensions for where 

they're being used. 

• Compress images: Reduce file size without losing too much quality using 

online tools or WordPress plugins. Examples of  online tools include 

Optimizilla, Compressor.io, TinyPNG.com, and Squoosh. 

• Use appropriate file formats: AVIF, WEBP, JPEG for photos, PNG for 

graphics with transparency. 
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Figure 27: TinyPNG tool showing different image formats and file sizes  

 

Website speed optimization (caching).  

Caching helps your website load faster for returning visitors.  

→ Explanation: When someone visits your website, their browser has to load 

everything—images, text, design files, and more. This takes time, especially 

if  your site is large or the visitor has a slow internet connection.  

 

Caching helps by storing a temporary copy of  

your website either: 

• On the visitor’s browser (so repeat 

visits are faster), or 

• On your web server (so the same 

content doesn’t get processed over and 

over). 

 

This means faster load times, a better user experience, and even better SEO 

rankings. 

Figure 28: LiteSpeed Cache plugin can speed up your website  
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Practical Example 

We’ll use beginner-friendly caching plugins like: 

• WP Rocket (paid, easy to use, very popular), or 

• LiteSpeed Cache (free and works best with LiteSpeed hosting). 

These plugins can: 

• Automatically cache your pages, 

• Compress your files for faster delivery, 

• And let you clear (reset) the cache with one click when you make updates.  

 

→ Tools like Google PageSpeed Insights help measure your site’s speed . 

 

 

Figure 29: A PageSpeed insight screenshot showing page performance metrics  

 

Website backups.  

Regularly backing up your website is essential in case something goes wrong (e.g., 

hacking, errors during updates).  

• Importance: Backups allow you to restore your website to a previous 

working state. 
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• Methods: We'll cover using backup plugins like UpdraftPlus, AIO WP 

Migration plugin or BackWPup to automate the backup process to a secure 

location (like cloud storage). 

 

 

Figure 30: UpdraftPlus, a popular website backup and restore plugin 

 

Basic security practices.  

Implementing simple security measures can significantly reduce the risk of  

attacks.  

• Strong Passwords: Using complex, unique passwords for your WordPress 

admin account and hosting account. 

• Keeping WordPress Updated: Ensuring your WordPress core, themes, 

and plugins are always updated to the latest versions, as these often include 

security patches. Enable automatic updates. 

• Limiting Login Attempts: Using plugins to prevent brute-force attacks by 

limiting the number of  failed login attempts. 

 

Lesson 12: Launching Your Website  

The moment you've been working towards! This lesson will guide you through the 

final steps before making your website live to the world. 
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Final checks before launch.  

Go through a checklist to ensure everything is working correctly:  

• Review all pages and posts for errors. 

• Test all links and forms. 

• Ensure your website is responsive on different devices. 

• Double-check your contact information. 

• Make sure your privacy policy and other legal pages are in place (if  needed).  

 

Going live.  

→ If  you've been working on a temporary domain: You'll need to update your 

domain name settings with your hosting provider to point to your live website. 

Your hosting support can usually assist with this.  

→ Ensure your "Search Engine Visibility" setting (in Settings > Reading) 

is unchecked. This allows search engines to start indexing your site. Website 

indexing is the process by which search engines like Google crawl and store a 

WordPress site’s pages in their database to display them in search results.  

 

 

Figure 31: Final checks before going live 
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Promoting your website.  

Once your site is live, let people know. The more people visit and interact with 

your site, the higher your chances of  ranking higher and being noticed even more.  

• Share your website link on your social media platforms. 

• Tell your friends, family, and colleagues. 

• Consider basic local listings if  applicable to your website's purpose.  

 

Lesson 13: Ongoing Maintenance & Updates  

WordPress updates (core, themes, plugins).  

Regularly updating WordPress core, your theme, and all your plugins is vital for 

security and compatibility.  

• Best Practice: Before running major updates, it's always a good idea to 

create a full website backup. 

• How to Update: You'll see notifications in your WordPress dashboard when 

updates are available. Simply click "Update Now." 

Content updates.  

Keep your website fresh and engaging by regularly adding new content (blog 

posts, new products, updated information). 

Monitoring website performance.  

Monitor your website's speed and uptime. There are various tools and hosting 

features that can help you monitor this, including Google PageSpeed Insights. 

 

Basic SEO maintenance.  

Continue to think about SEO by:  

• Creating high-quality, relevant content. 

• Promoting and driving traffic to your content 

• Using relevant keywords. 
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• Monitoring your search engine rankings (using tools like Google Search 

Console). 

• Getting backlinks from reputable websites. Backlinks are links from other 

websites that point to your WordPress site, helping improve its search 

engine ranking and credibility. 

 

 

 

 

 

 

 

 

 

  

Task: Perform a Manual Backup and Check Reading Settings.   

• Go to Tools > Export and export all content as an XML file (this is a 

basic manual backup). 

• Then, navigate to Settings > Reading and ensure that the 

"Discourage search engines from indexing this site" box is unchecked 

(assuming their practice site is ready to be "launched" for the purpose 

of  this exercise). 
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MODULE 5: QUIZ 

 

 

 
 
 
21. Why is it important to optimize images before launching your website?  

☐ a) To make them look more visually appealing. 

☐ b) To improve website loading speed and performance.  

☐ c) To ensure they are properly indexed by search engines.  

☐ d) To reduce the storage space used on your hosting server. 
  
22. What is website caching primarily used for?  

☐ a) Enhancing the security of  your website.  

☐ b) Speeding up website load times for returning visitors.  

☐ c) Organizing your website's content and media files.  

☐ d) Automatically backing up your website data. 
  
23. Why is it important to regularly back up your WordPress website?  

☐ a) To improve its search engine ranking.  

☐ b) To ensure you have a copy of  your website in case of  errors, hacking, or other issues.  

☐ c) To automatically update your themes and plugins.  

☐ d) To monitor your website's traffic and analytics. 
  
24. What is the first crucial step to take when your website is ready to be publicly 
accessible?  

☐ a) Install all recommended plugins.  

☐ b) Submit your sitemap to search engines.  

☐ c) Ensure the "Discourage search engines from indexing this site" option is unchecked.  

☐ d) Share your website link on social media.  
 
25. Why is it important to keep your WordPress core, themes, and plugins updated?  

☐ a) To ensure you have the latest design trends.  

☐ b) To access new features and improve compatibility.  

☐ c) To address security vulnerabilities and maintain stability.  

☐ d) All of  the above. 
 
 
 
 
 

Learner’s Name: ______________________________________  

Batch: ___________________ Month: ___________Year _____ 
Link5: Scan to take 

interactive quiz online 

https://sntechpros.com/quiz-answers
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Hands-on Project: Launch & Maintenance  

Goal: Optimize, launch, and maintain the Awesome Bakery website.  
Tasks: 

1. Optimize Images: 
o Resize images (e.g., banner to 1920x600 pixels) using a tool like Squoosh or 

TinyPNG. 
o Compress images to reduce file size (aim for <200 KB per image).  
o Use WEBP or JPEG formats for photos. 
o Upload optimized images to the Media Library. 
o Reference Figure 24: TinyPNG tool. 

2. Set Up Caching: 
o Install and activate LiteSpeed Cache (or WP Rocket if  preferred). 
o Enable page caching and file compression in the plugin settings.  
o Test site speed using Google PageSpeed Insights. 
o Reference Figure 26: PageSpeed Insights screenshot . 

3. Back Up the Site: 
o Install and activate UpdraftPlus. 
o Configure automatic backups to a cloud service like Google Drive.  
o Perform a manual backup before launching. 
o Reference Figure 27: UpdraftPlus plugin . 

4. Perform Final Checks: 
o Review all pages for typos and broken links. 
o Test the contact form and navigation menu. 
o Check responsiveness on mobile and tablet devices. 
o Ensure a privacy policy page is added (use a template from WPBeginner).  
o Go to Settings > Reading and uncheck “Discourage search engines from 

indexing this site.” 
o Reference Figure 28: Final checks before going live . 

5. Launch the Website: 
o Confirm the domain (awesomebakery.com) points to your hosting server (check 

DNS settings). 
o Visit awesomebakery.com to ensure the site is live. 
o Submit the sitemap (from Yoast SEO) to Google Search Console.  

6. Promote the Website: 
o Share the site link on social media (e.g., Facebook, Instagram). 
o Email the link to friends and family. 
o Add the site to local business listings (e.g., Google My Business).  

7. Ongoing Maintenance: 
o Check for WordPress, theme, and plugin updates weekly in the dashboard.  
o Add a new blog post monthly (e.g., “Seasonal Pastry Specials”).  
o Monitor site speed with Google PageSpeed Insights. 
o Use Google Search Console to track SEO performance and add relevant 

keywords. 
Deliverable: A live, optimized, and secure Awesome Bakery website with a plan for ongoing 
maintenance 
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Quiz Answers 
Scan this code to access the interactive quiz 

  

Module 1: Foundations & Planning 

1. What is the primary purpose of a Content Management System (CMS) like WordPress?  

Answer: b) To easily create and manage website content without extensive coding knowledge. Explanation: A CMS like 

WordPress allows users to build and manage websites using a user -friendly interface, eliminating the need for advanced 

coding skills. 

 

2. Which of the following best describes a domain name?  

Answer: c) The unique web address that visitors type to access a website. Explanation: A domain name (e.g., 

yourwebsite.com) is the address users enter in their browser to visit your site, distinct from hosting or software.  

 

3. What is web hosting? 

Answer: b) The service of storing your website's files on a server so they can be accessed online. Explanation: Hosting 

provides server space to store your website’s files, making them accessible on the internet.  

 

4. What is the role of DNS (Domain Name System)? 

Answer: c) To connect domain names to the IP addresses of web servers. Explanation: DNS acts like a phonebook, 

translating domain names (e.g., yourwebsite.com) into IP addresses to locate your hosting server.  

 

5. When planning your website, what is the first and most crucial question to consider?  

Answer: b) What is the purpose of my website? Explanation: Defining the website’s purpose guides all other decisions, 

such as content, design, and target audience. 

 

Module 2: WordPress Installation & Setup 

6. Which is generally considered the easiest way to install WordPress for beginners?  

Answer: c) One-click installation through the hosting control panel. Explanation: One-click installation tools (e.g., 

Softaculous) simplify the process by automating WordPress setup with minimal input.  

 

7. After installing WordPress, how do you typically access the administrative dashboard?  

Answer: c) By visiting yourdomain.com/wp-admin/ Explanation: The WordPress dashboard is accessed via 

yourdomain.com/wp-admin, where you enter your admin credentials.  

 

8. In WordPress settings, what is the primary purpose of configuring permalinks?  

Answer: c) To define the structure and appearance of your website's URLs. Explanation: Permalinks control URL 

formats (e.g., yourdomain.com/post-name), making them user-friendly and SEO-optimized. 

 

9. Under WordPress General Settings, what is the "Tagline"?  

Answer: b) A short descriptive phrase for your website. Explanation: The tagline is a brief slogan or description (e.g., 

“Freshly Baked Goods Daily”) displayed on your site.  

 

10. In WordPress, what is the significance of the "Search Engine Visibility" setting under Reading?  

Answer: c) It determines whether search engines are allowed to index your website. Explanation: Unchecking this 

option allows search engines like Google to index your site, making it discoverable online.  

 

Module 3: Themes & Customization 

11. What is the main function of a WordPress theme? 

Answer: c) To control the visual design and layout of your website. Explanation: Themes determine your site’s 

appearance, including colors, fonts, and layout, without affecting content.  

https://sntechpros.com/quiz-answers
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12. Where can you typically find and install free WordPress themes?  

Answer: b) Through the WordPress dashboard under Appearance > Themes > Add New. Explanation: Free themes 

are accessible directly in the WordPress dashboard via the theme directory.  

13. What is the WordPress Customizer primarily used for?  

Answer: c) Visually adjusting various aspects of your active theme. Explanation: The Customizer allows real-time visual 

changes to theme settings like colors, menus, and widgets.  

 

14. What is CSS (Cascading Style Sheets) primarily responsible for in WordPress?  

Answer: c) The visual styling and presentation of your website. Explanation: CSS controls design elements like fonts, 

colors, and spacing, enhancing your theme’s appearance.  

 

15. Where do you typically create and manage the main navigation menu of your WordPress website?  

Answer: c) Appearance > Menus Explanation: The Menus section under Appearance lets you create and organize your 

site’s navigation menu. 

 

Module 4: Plugins & Functionality 

16. What is the primary purpose of a WordPress plugin?  

Answer: b) To add new features and extend the functionality of your WordPress site. Explanation: Plugins enhance 

your site with features like SEO, security, or e-commerce without requiring coding. 

 

17. Where is the main section in the WordPress dashboard to install and manage plugins?  

Answer: d) Plugins Explanation: The Plugins section in the dashboard allows you to search, install, and manage 

plugins. 

 

18. Which type of plugin is crucial for helping your website appear in search engine results like Google?  

Answer: c) SEO plugin Explanation: SEO plugins (e.g., Yoast SEO) optimize content for better visibility in search 

engine results. 

 

19. What is the main benefit of using a page builder plugin?  

Answer: b) It allows you to create complex page layouts visually using drag -and-drop. Explanation: Page builders like 

Elementor simplify design by offering a visual, drag-and-drop interface. 

 

20. What is the name of the most popular e-commerce plugin for WordPress? 

Answer: b) WooCommerce Explanation: WooCommerce is the leading plugin for creating and managing online stores 

in WordPress. 

 

Module 5: Launch & Maintenance 

21. Why is it important to optimize images before launching your website?  

Answer: b) To improve website loading speed and performance. Explanation: Optimized images reduce file sizes, 

making your site load faster and improving user experience.  

 

22. What is website caching primarily used for? 

Answer: b) Speeding up website load times for returning visitors. Explanation: Caching stores temporary copies of 

your site, reducing load times for repeat visitors. 

 

23. Why is it important to regularly back up your WordPress website?  

Answer: b) To ensure you have a copy of your website in case of errors, hacking, or other issues. Explanation: Backups 

allow you to restore your site if data is lost due to hacks or errors.  

 

24. What is the first crucial step to take when your website is ready to be publicly accessible?  

Answer: c) Ensure the "Discourage search engines from indexing this site" option is unchecked. Explanation: 

Unchecking this option allows search engines to index your site, making it visible online.  
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25. Why is it important to keep your WordPress core, themes, and plugins updated?  

Answer: c) To address security vulnerabilities and maintain stability. Explanation: Updates include security patches and 

compatibility improvements, ensuring your site remains secure and functional.  

 

Further Reading 
- WordPress.org: Official WordPress documentation (wordpress.org) 

- WPBeginner: Beginner-friendly tutorials (wpbeginner.com) 

- Bluehost: Reliable hosting for WordPress (bluehost.com) 

- Yoast SEO: SEO plugin guide (yoast.com) 

We’re committed to improving this course! Share your feedback on 

our website at sntechpros.com/wordpress-web-design-for-

beginners/#feedback 

 

Hands-on Project Completion  

Our Awesome Bakery project is now complete, you should have a professional WordPress website for 

Awesome Bakery, featuring: 

• A branded, responsive design with a clear navigation menu. 

• Key pages (Home, About Us, Menu, Contact) and a blog post.  

• Essential plugins for SEO, security, and functionality. 

• Optimized performance and a maintenance plan. 

Next Steps: 

• Experiment with adding more products to the Menu page. 

• Explore WooCommerce to set up an online store (optional).  

• Continue learning with resources from wordpress.org, wpbeginner.com, or sntechpros.com 

 

http://www.sntechpros.com/wordpress-web-designer-for-beginners/#feedback
http://www.sntechpros.com/wordpress-web-designer-for-beginners/#feedback

